import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:more|most)\\s+\\w*ly(*SKIP)(*F)|\\w*ly\\b";
final String string = "fastly onffly fly incomprehensibly totaly happily \n\n"
+ "lily sly more happily \n\n"
+ "most seriously";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}