# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4})\b.*on (?!\1)\b((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}\b"
test_str = ("10.10.10.10 | computer name | John Doe> some text username on 11.11.11.11\n\n"
"10.10.10.10 | computer name | John Doe> some text username on 10.10.10.10\n\n"
"255.255.255.255 | computer name | John Doe> some text username on 255.255.255.255\n\n"
"255.255.255.244 | computer name | John Doe> some text username on 255.255.255.255\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.