import Foundation
let pattern = #"\b(((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4})\b.*on (?!\1)\b((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
10.10.10.10 | computer name | John Doe> some text username on 11.11.11.11
10.10.10.10 | computer name | John Doe> some text username on 10.10.10.10
255.255.255.255 | computer name | John Doe> some text username on 255.255.255.255
255.255.255.244 | computer name | John Doe> some text username on 255.255.255.255
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)