const regex = /^Case title: +(?<caseTitle>.*\S) *\n+Client: +(?<client>.*?\S) *\n+Origin: +(?<origin>.*?\S) *\n+Contact: +(?<contact>.*?\S) *\n+DSM: +(?<dsm>.*?) *\n+CSM: +(?<csm>.*?\S) *\n+Assigned To: +(?<assignedTo>.*?\S) *\n+Due Date: +(?<dueDate>.*?\S) *\n+Description: +(?<desc>.*?\S) *$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Case title: +(?<caseTitle>.*\\S) *\\n+Client: +(?<client>.*?\\S) *\\n+Origin: +(?<origin>.*?\\S) *\\n+Contact: +(?<contact>.*?\\S) *\\n+DSM: +(?<dsm>.*?) *\\n+CSM: +(?<csm>.*?\\S) *\\n+Assigned To: +(?<assignedTo>.*?\\S) *\\n+Due Date: +(?<dueDate>.*?\\S) *\\n+Description: +(?<desc>.*?\\S) *$', 'gmi')
const str = `Case title: Sample Test case 9
Client: 8688211
Origin: Email
Contact: testing@me.com
DSM: testContact1
CSM: testContact1
Assigned To: testing@me.com
Due Date: 06/28/2023
Description: Sample description 9
Case title: Sample Test case 9
Client: 8688211
Origin: Email
Contact: testing@me.com
DSM: testContact1
CSM: testContact1
Assigned To: testing@me.com
Due Date: 06/28/2023
Description: Sample description 9 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}