re = /^Case title: +(?<caseTitle>.*\S) *\n+Client: +(?<client>.*?\S) *\n+Origin: +(?<origin>.*?\S) *\n+Contact: +(?<contact>.*?\S) *\n+DSM: +(?<dsm>.*?) *\n+CSM: +(?<csm>.*?\S) *\n+Assigned To: +(?<assignedTo>.*?\S) *\n+Due Date: +(?<dueDate>.*?\S) *\n+Description: +(?<desc>.*?\S) *$/mi
str = 'Case title: Sample Test case 9
Client: 8688211
Origin: Email
Contact: testing@me.com
DSM: testContact1
CSM: testContact1
Assigned To: testing@me.com
Due Date: 06/28/2023
Description: Sample description 9
Case title: Sample Test case 9
Client: 8688211
Origin: Email
Contact: testing@me.com
DSM: testContact1
CSM: testContact1
Assigned To: testing@me.com
Due Date: 06/28/2023
Description: Sample description 9 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end