use strict;
my $str = '1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data
A. Data sub 1 as fda sdf
B. Data sub 2 asfasf dasdf asd f
2. Data
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
3. Data
A. Data sub 1
A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub
B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub
D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd
';
my $regex = qr/\s*\n(?=\d+\.)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}