# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*\n(?=\d+\.)"
test_str = ("1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd1. Data\n"
" A. Data sub 1 as fda sdf\n"
" B. Data sub 2 asfasf dasdf asd f\n"
"2. Data\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n"
"3. Data\n"
" A. Data sub 1\n"
" A. Data sub Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" B. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" C. Data sub Data sub Data sub Data sub Data sub Data sub Data sub \n"
" D. Data sub 4 asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasdf asdf asdf asdf asdf asdfasd\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.