import re
regex = re.compile(r"(?=.)uml", flags=re.MULTILINE)
test_str = ("ä\n"
"&zuml\n"
"ö\n"
"ë ")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)