$re = '/^[^\/.]+/m';
$str = 'job.batch/monitoring-cloud12390200
service/monitoring-opentt-collector';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);