use strict;
my $str = '[9:14:51 AM] Jeff: If you could just do me a favoure and list all these concerns and in a mail and if you have any ideas that you might want to implement so that I can get everybodys notes.
[9:14:56 AM] Timmy: in terms of websites or domains or DNSs I have no clue about setup
[9:15:19 AM | Edited 9:15:25 AM] Jeff: That, I will get Sam and Frodo involved in
[9:16:01 AM] Jeff: I am stepping out quickly';
my $regex = qr/\[(?<time>(?:[\d]+\:[\d]+:[\d]+)\s+(?:AM|PM))(?:\s+\|\s+\w+\s+(?<edited>(?:[\d]+\:[\d]+:[\d]+)\s+(?:AM|PM)))?\]\s+(?<author>\w+)\:\s+(?<message>[\w\s,.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}