package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)counter\([^)]*\)`)
var str = `counter()
counter(123, "this string has (nested) parentheses")
counter(123, "this string has mis-matched)( parentheses")
counter(item)" " attr(data) "" counter(item1,decimal) url('test.jpeg') "hi" attr(xyz);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}