re = /counter\([^)]*\)/m
str = 'counter()
counter(123, "this string has (nested) parentheses")
counter(123, "this string has mis-matched)( parentheses")
counter(item)" " attr(data) "" counter(item1,decimal) url(\'test.jpeg\') "hi" attr(xyz);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end