using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bW[12]00\b(?!\s+Z92[23]\b).*?\bZ941\b";
string input = @"W100 Z923 W200 A456 W200 B234 A234 Z941";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}