$re = '/\bW[12]00\b(?!\s+Z92[23]\b).*?\bZ941\b/m';
$str = 'W100 Z923 W200 A456 W200 B234 A234 Z941';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);