re = /^(?:https|http)\:\/\/github\.com\/([a-zA-Z0-9]+)\/([a-zA-Z0-9\.\-_]+)$/i
str = 'https://github.com/shoaiyb/sysacss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end