const regex = /\/\d{10,11}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\d{10,11}$', 'gm')
const str = `test/1234567890
test/1234567890abc
test/abc1234567a890abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}