const regex = /(?<=\G(?!^)|clients_field_)(\w*)-/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\G(?!^)|clients_field_)(\\w*)-', 'g')
const str = `"clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6": "info@domain.com",
"clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b": "2017-07-26"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);