import re
regex = re.compile(r"(?<=\G(?!^)|clients_field_)(\w*)-")
test_str = ("\"clients_field_4741a6c5-3855-4455-b487-0b38b0038ae6\": \"info@domain.com\",\n"
"\"clients_field_78f225e0-1a78-4930-b251-ad2217baeb1b\": \"2017-07-26\"")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)