use strict;
my $str = 'const path =  require  ("path") ;
let path = require("path");
var path = require("path");';
my $regex = qr/((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\(")(\w+)("\s*\)\s*;))/p;
my $subst = '$4,$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";