#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(n|an_nh)_(vc_v|naca_(i|E[1-4]|k_[1-4][1-4]))"
Local $sString = "Should match:" & @CRLF & _
"an_nh_naca_i" & @CRLF & _
"an_nh_naca_k_12" & @CRLF & _
"an_nh_naca_k_21" & @CRLF & _
"an_nh_naca_k_23" & @CRLF & _
"an_nh_naca_k_32" & @CRLF & _
"an_nh_naca_k_34" & @CRLF & _
"an_nh_naca_k_43" & @CRLF & _
"an_nh_naca_k_41" & @CRLF & _
"an_nh_naca_k_14" & @CRLF & _
"an_nh_naca_E1" & @CRLF & _
"an_nh_naca_E2" & @CRLF & _
"an_nh_naca_E3" & @CRLF & _
"an_nh_naca_E4" & @CRLF & _
"an_nh_vc_v" & @CRLF & _
"n_naca_i" & @CRLF & _
"n_naca_k_12" & @CRLF & _
"n_naca_k_21" & @CRLF & _
"n_naca_k_23" & @CRLF & _
"n_naca_k_32" & @CRLF & _
"n_naca_k_34" & @CRLF & _
"n_naca_k_43" & @CRLF & _
"n_naca_k_41" & @CRLF & _
"n_naca_k_14" & @CRLF & _
"n_naca_E1" & @CRLF & _
"n_naca_E2" & @CRLF & _
"n_naca_E3" & @CRLF & _
"n_naca_E4" & @CRLF & _
"n_vc_v" & @CRLF & _
"" & @CRLF & _
"Should not match:" & @CRLF & _
"an_nh_naca_F1_3n_i" & @CRLF & _
"an_nh_naca_F1_3n_o" & @CRLF & _
"n_naca_F1_3n_i" & @CRLF & _
"n_naca_F1_3n_o"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")