import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(n|an_nh)_(vc_v|naca_(i|E[1-4]|k_[1-4][1-4]))";
final String string = "Should match:\n"
+ "an_nh_naca_i\n"
+ "an_nh_naca_k_12\n"
+ "an_nh_naca_k_21\n"
+ "an_nh_naca_k_23\n"
+ "an_nh_naca_k_32\n"
+ "an_nh_naca_k_34\n"
+ "an_nh_naca_k_43\n"
+ "an_nh_naca_k_41\n"
+ "an_nh_naca_k_14\n"
+ "an_nh_naca_E1\n"
+ "an_nh_naca_E2\n"
+ "an_nh_naca_E3\n"
+ "an_nh_naca_E4\n"
+ "an_nh_vc_v\n"
+ "n_naca_i\n"
+ "n_naca_k_12\n"
+ "n_naca_k_21\n"
+ "n_naca_k_23\n"
+ "n_naca_k_32\n"
+ "n_naca_k_34\n"
+ "n_naca_k_43\n"
+ "n_naca_k_41\n"
+ "n_naca_k_14\n"
+ "n_naca_E1\n"
+ "n_naca_E2\n"
+ "n_naca_E3\n"
+ "n_naca_E4\n"
+ "n_vc_v\n\n"
+ "Should not match:\n"
+ "an_nh_naca_F1_3n_i\n"
+ "an_nh_naca_F1_3n_o\n"
+ "n_naca_F1_3n_i\n"
+ "n_naca_F1_3n_o";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}