#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\(?(0{1,2}|\+)\d{1,2}\)?)?(([ -]*\d+){8,20})+"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"https://asd.com/20441235534-aaaaaaaaaaa-" & @CRLF & _
"" & @CRLF & _
"202460676" & @CRLF & _
"" & @CRLF & _
"aasdasd 202460676" & @CRLF & _
"" & @CRLF & _
"https://asd.com/20441235534" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"202460676-" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"10 text" & @CRLF & _
"1234 text" & @CRLF & _
"text 123" & @CRLF & _
"" & @CRLF & _
"00491234567890" & @CRLF & _
"+491234567890" & @CRLF & _
"" & @CRLF & _
"0123-4567890" & @CRLF & _
"" & @CRLF & _
"0123 4567 789" & @CRLF & _
"0123 456 7890" & @CRLF & _
"0123 45 67 789" & @CRLF & _
"" & @CRLF & _
"+490123 4567 789" & @CRLF & _
"+490123 456 7890" & @CRLF & _
"+49 123 45 67 789" & @CRLF & _
"" & @CRLF & _
"123 4567 789" & @CRLF & _
"123 456 7890" & @CRLF & _
"123 45 67 789" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"+49 1234567890" & @CRLF & _
"+491234567890" & @CRLF & _
"" & @CRLF & _
"0049 1234567890" & @CRLF & _
"0049 1234 567 890" & @CRLF & _
"" & @CRLF & _
"(0049)1234567890" & @CRLF & _
"(+49)1234567890" & @CRLF & _
"" & @CRLF & _
"(0049) 1234567890" & @CRLF & _
"(+49) 1234567890" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"text text (0049) 1234567890 text text" & @CRLF & _
"text text (+49) 1234567890 text text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")