import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(?(0{1,2}|\\+)\\d{1,2}\\)?)?(([ -]*\\d+){8,20})+";
final String string = "\n\n"
+ "https://asd.com/20441235534-aaaaaaaaaaa-\n\n"
+ "202460676\n\n"
+ "aasdasd 202460676\n\n"
+ "https://asd.com/20441235534\n\n\n"
+ "202460676-\n\n\n\n"
+ "10 text\n"
+ "1234 text\n"
+ "text 123\n\n"
+ "00491234567890\n"
+ "+491234567890\n\n"
+ "0123-4567890\n\n"
+ "0123 4567 789\n"
+ "0123 456 7890\n"
+ "0123 45 67 789\n\n"
+ "+490123 4567 789\n"
+ "+490123 456 7890\n"
+ "+49 123 45 67 789\n\n"
+ "123 4567 789\n"
+ "123 456 7890\n"
+ "123 45 67 789\n\n\n"
+ "+49 1234567890\n"
+ "+491234567890\n\n"
+ "0049 1234567890\n"
+ "0049 1234 567 890\n\n"
+ "(0049)1234567890\n"
+ "(+49)1234567890\n\n"
+ "(0049) 1234567890\n"
+ "(+49) 1234567890\n\n\n\n"
+ "text text (0049) 1234567890 text text\n"
+ "text text (+49) 1234567890 text text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}