using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\s*\(['""]?(.*?)['""]?\)(?![^;\s])";
string input = @"background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)
/* 2019-07-03 13:38:44 */
background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)
@charset ""UTF-8"";@font-face{font-family:lato_blackregular;src:url(""../../Common/common/fonts/lato/lato-black-webfont.eot"");src:url(""../../Common/common/fonts/lato/lato-black-webfont.eot?#iefix"") format(""embedded-opentype""),url(""../../Common/common/fonts/lato/lato-black-webfont.woff"") format(""woff""),url(""../../Common/common/fonts/lato/lato-black-webfont.ttf"") format(""truetype""),url(""../../Common/common/fonts/lato/lato-black-webfont.svg?#lato_blackregular"") format(""svg"");font-weight:400;font-style:normal}@font-face{font-family:latobold;src:url(""../../Common/common/fonts/lato/lato-bold-webfont.eot"");src:url(""../../Common/common/fonts/lato/lato-bold-webfont.eot?#iefix"") format(""embedded-opentype""),url(""../../Common/common/fonts/lato/lato-bold-webfont.woff"") format(""woff""),url(""../../Common/common/fonts/lato/lato-bold-webfont.ttf"") format(""truetype""),url(""../../Common/common/fonts/lato/lato-bold-webfont.svg?#latobold"") format(""svg"");font-weight:400;font-style:normal}@font-face{font-family:latoregular;src:url(""../../Common/common/fonts/lato/lato-regular-webfont.eot"");src:url(""../../Common/common/fonts/lato/lato-regular-webfont.eot?#iefix"") format(""embedded-opentype""),url(""../../Common/common/fonts/lato/lato-regular-webfont.woff"") format(""woff""),url(""../../Common/common/fonts/lato/lato-regular-webfont.ttf"") format(""truetype""),url(""../../Common/common/fonts/lato/lato-regular-webfont.svg?#latoregular"") format(""svg"");font-weight:400;font-style:normal}@font-face{font-family:latolight;src:url(""../../Common/common/fonts/lato/lato-light-webfont.eot"");src:url(""../../Common/common/fonts/lato/lato-light-webfont.eot?#iefix"") format(""embedded-opentype""),url(""../../Common/common/fonts/lato/lato-light-webfont.woff"") format(""woff""),url(""../../Common/common/fonts/lato/lato-light-webfont.ttf"") format(""truetype""),url(""../../Common/common/fonts/lato/lato-light-webfont.svg?#latoregular"") format(""svg"");font-weight:400;font-style:normal}@font-face{font-family:lato_lightregular;src:url(""../../Common/common/fonts/lato/lato-light-webfont.eot"");src:url(""../../Common/common/fonts/lato/lato-light-webfont.eot?#iefix"") format(""embedded-opentype""),url(""../../Common/common/fonts/lato/lato-light-webfont.woff"") format(""woff""),url(""../../Common/common/fonts/lato/lato-light-webfont.ttf"") ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}