# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url\s*\(['\"]?(.*?)['\"]?\)(?![^;\s])"
test_str = ("background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)\n"
"/* 2019-07-03 13:38:44 */\n"
"background:url(/uploads/2019/03/0002-image(thumbnail_product).jpg)\n"
"@charset \"UTF-8\";@font-face{font-family:lato_blackregular;src:url(\"../../Common/common/fonts/lato/lato-black-webfont.eot\");src:url(\"../../Common/common/fonts/lato/lato-black-webfont.eot?#iefix\") format(\"embedded-opentype\"),url(\"../../Common/common/fonts/lato/lato-black-webfont.woff\") format(\"woff\"),url(\"../../Common/common/fonts/lato/lato-black-webfont.ttf\") format(\"truetype\"),url(\"../../Common/common/fonts/lato/lato-black-webfont.svg?#lato_blackregular\") format(\"svg\");font-weight:400;font-style:normal}@font-face{font-family:latobold;src:url(\"../../Common/common/fonts/lato/lato-bold-webfont.eot\");src:url(\"../../Common/common/fonts/lato/lato-bold-webfont.eot?#iefix\") format(\"embedded-opentype\"),url(\"../../Common/common/fonts/lato/lato-bold-webfont.woff\") format(\"woff\"),url(\"../../Common/common/fonts/lato/lato-bold-webfont.ttf\") format(\"truetype\"),url(\"../../Common/common/fonts/lato/lato-bold-webfont.svg?#latobold\") format(\"svg\");font-weight:400;font-style:normal}@font-face{font-family:latoregular;src:url(\"../../Common/common/fonts/lato/lato-regular-webfont.eot\");src:url(\"../../Common/common/fonts/lato/lato-regular-webfont.eot?#iefix\") format(\"embedded-opentype\"),url(\"../../Common/common/fonts/lato/lato-regular-webfont.woff\") format(\"woff\"),url(\"../../Common/common/fonts/lato/lato-regular-webfont.ttf\") format(\"truetype\"),url(\"../../Common/common/fonts/lato/lato-regular-webfont.svg?#latoregular\") format(\"svg\");font-weight:400;font-style:normal}@font-face{font-family:latolight;src:url(\"../../Common/common/fonts/lato/lato-light-webfont.eot\");src:url(\"../../Common/common/fonts/lato/lato-light-webfont.eot?#iefix\") format(\"embedded-opentype\"),url(\"../../Common/common/fonts/lato/lato-light-webfont.woff\") format(\"woff\"),url(\"../../Common/common/fonts/lato/lato-light-webfont.ttf\") format(\"truetype\"),url(\"../../Common/common/fonts/lato/lato-light-webfont.svg?#latoregular\") format(\"svg\");font-weight:400;font-style:normal}@font-face{font-family:lato_lightregular;src:url(\"../../Common/common/fonts/lato/lato-light-webfont.eot\");src:url(\"../../Common/common/fonts/lato/lato-light-webfont.eot?#iefix\") format(\"embedded-opentype\"),url(\"../../Common/common/fonts/lato/lato-light-webfont.woff\") format(\"woff\"),url(\"../../Common/common/fonts/lato/lato-light-webfont.ttf\") ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.