#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^.\n=]*\.[^.\n=]*="
Local $sString = "ac.def=1" & @CRLF & _
"and" & @CRLF & _
"xy.z.kt='10'" & @CRLF & _
"and" & @CRLF & _
"k.t=1" & @CRLF & _
"or" & @CRLF & _
"xy.z.kt.lm='10'" & @CRLF & _
"" & @CRLF & _
"ac.def=1.5" & @CRLF & _
"def=1.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")