import re
regex = re.compile(r"^[^.\n=]*\.[^.\n=]*=", flags=re.MULTILINE)
test_str = ("ac.def=1\n"
"and\n"
"xy.z.kt='10'\n"
"and\n"
"k.t=1\n"
"or\n"
"xy.z.kt.lm='10'\n\n"
"ac.def=1.5\n"
"def=1.5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")