re = /(["'])(?:(?=(\\?))\2.)*?\1/m
str = 'Must match
--------
"a"
\'a a\'
\'a"a\'
"a\'\'a"
"a\'\\"\\"\'a"
"\\"\\"\\""
--------
Must not match
--------
"a
"\\"
"a\'
\'a"
--------
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end