import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<pun1>\\d{3})\\s+(?P<pun2>\\d{6})(\\s+(?P<pun3>[01oO])(\\s+(?P<pun4>\\d{4}))?)?\\s.*\\s(?P<amt>\\d+\\.\\d\\d)\\s";
final String string = "105297 003 002394 o 0000 20891 0.00 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}