const regex = /(?P<pun1>\d{3})\s+(?P<pun2>\d{6})(\s+(?P<pun3>[01oO])(\s+(?P<pun4>\d{4}))?)?\s.*\s(?P<amt>\d+\.\d\d)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<pun1>\\d{3})\\s+(?P<pun2>\\d{6})(\\s+(?P<pun3>[01oO])(\\s+(?P<pun4>\\d{4}))?)?\\s.*\\s(?P<amt>\\d+\\.\\d\\d)\\s', 'gm')
const str = `105297 003 002394 o 0000 20891 0.00 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}