import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=(?:\\w*\\d){2}\\w*)(?=(?:\\w*[A-Za-z]){2}\\w*)\\w{8}\\b";
final String string = "yi12345678\n"
+ "i1234567\n"
+ "i12345u8\n"
+ "12345678 \n"
+ "papave23 ciao il mio pin papaver1 รจ reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y\n"
+ "dssdsdsffvdffvdfv \n"
+ "389223897894237234894722348972348924\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}