const regex = /\b(?=(?:\w*\d){2}\w*)(?=(?:\w*[A-Za-z]){2}\w*)\w{8}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=(?:\\w*\\d){2}\\w*)(?=(?:\\w*[A-Za-z]){2}\\w*)\\w{8}\\b', 'g')
const str = `yi12345678
i1234567
i12345u8
12345678
papave23 ciao il mio pin papaver1 รจ reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y
dssdsdsffvdffvdfv
389223897894237234894722348972348924
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}