re = /[^ ]+ [^ ]+, [^ ]+( )/
str = 'Paulsen Kehr, Diego Schalper SepĂșlveda, Diego Von Housen Kush, Terry
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end