#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?:\R|\A).+){3}\K\R.+"
Local $sString = "1" & @CRLF & _
"00:07:14,120 --> 00:07:16,953" & @CRLF & _
"[French line]" & @CRLF & _
"[Russian line]" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:07:16,960 --> 00:07:19,952" & @CRLF & _
"[French line]" & @CRLF & _
"[Russian line]" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:07:21,240 --> 00:07:24,835" & @CRLF & _
"[French line]" & @CRLF & _
"[Russian line]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)