# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:\R|\A).+){3}\K\R.+"
test_str = ("1\n"
"00:07:14,120 --> 00:07:16,953\n"
"[French line]\n"
"[Russian line]\n\n"
"2\n"
"00:07:16,960 --> 00:07:19,952\n"
"[French line]\n"
"[Russian line]\n\n"
"3\n"
"00:07:21,240 --> 00:07:24,835\n"
"[French line]\n"
"[Russian line]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.