use strict;
my $str = 'This is some temperature 30° c - 50 ° c 2°c 34.5 °c
30°c - 40 °c and "30° - 40
30c - 50 °c" or 30c - 40';
my $regex = qr/-?\d+(?:\.\d+)?(?:\s*°)?(?:\s*c)?(?:\s*-\s*-?\d+(?:\.\d+)?(?:\s*°)?(?:\s*c)?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}