re = /-?\d+(?:\.\d+)?(?:\s*°)?(?:\s*c)?(?:\s*-\s*-?\d+(?:\.\d+)?(?:\s*°)?(?:\s*c)?)?/m
str = 'This is some temperature 30° c - 50 ° c 2°c 34.5 °c
30°c - 40 °c and "30° - 40
30c - 50 °c" or 30c - 40'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end