import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((.+\\n)*(.*\\.\\n))";
final String string = "Diagnosis of one of the following: A) Neovascular (wet) age-related\n"
+ "macular degeneration OR B) Macular edema following retinal vein\n"
+ "occlusion, OR C) Diabetic macular edema OR D) Diabetic retinopathy in\n"
+ "patients with diabetic macular edema. More text here.\n\n"
+ "PA Criteria\n\n"
+ "Criteria Details\n\n\n"
+ "Eylea (s)\n\n"
+ "Products Affected\n"
+ " EYLEA\n\n"
+ "Exclusion\n"
+ "Criteria\n\n"
+ "Required\n"
+ "Medical\n"
+ "Information\n\n"
+ "Age Restrictions\n\n"
+ "Prescriber\n"
+ "Restrictions\n\n"
+ "Coverage\n"
+ "Duration\n\n"
+ "Other Criteria\n\n"
+ "Off Label Uses\n\n\n\n\n\n\n\n\n\n\n\n"
+ "12 months\n\n"
+ "Indications\n\n"
+ "All Medically-accepted Indications.\n\n"
+ "Formulary ID 20276, Version 12\n\n"
+ "101";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}