# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((.+\n)*(.*\.\n))"
test_str = ("Diagnosis of one of the following: A) Neovascular (wet) age-related\n"
"macular degeneration OR B) Macular edema following retinal vein\n"
"occlusion, OR C) Diabetic macular edema OR D) Diabetic retinopathy in\n"
"patients with diabetic macular edema. More text here.\n\n"
"PA Criteria\n\n"
"Criteria Details\n\n\n"
"Eylea (s)\n\n"
"Products Affected\n"
" EYLEA\n\n"
"Exclusion\n"
"Criteria\n\n"
"Required\n"
"Medical\n"
"Information\n\n"
"Age Restrictions\n\n"
"Prescriber\n"
"Restrictions\n\n"
"Coverage\n"
"Duration\n\n"
"Other Criteria\n\n"
"Off Label Uses\n\n\n\n\n\n\n\n\n\n\n\n"
"12 months\n\n"
"Indications\n\n"
"All Medically-accepted Indications.\n\n"
"Formulary ID 20276, Version 12\n\n"
"101")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.