import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!foo).)+$";
final String string = "foo lkjlkj\n"
+ "bar\n"
+ "oof\n"
+ "fof\n\n"
+ "thidls foo dflaksjdf\n\n"
+ "thasdfd\n"
+ "asdfasd\n"
+ "sd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}