$re = '/([0-9]{9})(?!.*\1)/m';
$str = '141271999 243306211 172266710 172266710 172266710';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);