re = /([0-9]{9})(?!.*\1)/m
str = '141271999 243306211 172266710 172266710 172266710'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end