package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?\d+(\.\d+)?`)
var str = `0
0.1
2.3
2
20000
-200.000001
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}