$re = '/-?\d+(\.\d+)?/';
$str = '0
0.1
2.3
2
20000
-200.000001
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);