using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1?\s?(\d{3}|\([0-9]{3}\))[-\s]\d{3}[-\s]\d{4}|\d{10}|^1?\([0-9]{3}\)\d{3}[-\s]\d{4}";
string input = @"(6054756961)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}