re = /^1?\s?(\d{3}|\([0-9]{3}\))[-\s]\d{3}[-\s]\d{4}|\d{10}|^1?\([0-9]{3}\)\d{3}[-\s]\d{4}/m
str = '(6054756961)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end