using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/\*(?:[^\*]|\**[^\*\/])*\*+\/)|(?:\/\/[\S ]*)";
string input = @"/*field.activate(true);*/
//asdfasdf
/*
field.activate(true);
*
*/
/*
*/
/****
* Common multi-line comment style.
****/
/****
* Another common multi-line comment style.
*/
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}