$re = '/(?:\/\*(?:[^\*]|\**[^\*\/])*\*+\/)|(?:\/\/[\S ]*)/';
$str = '/*field.activate(true);*/
//asdfasdf
/*
field.activate(true);
*
*/
/*
*/
/****
* Common multi-line comment style.
****/
/****
* Another common multi-line comment style.
*/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);