const regex = /\s\s/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s\\s', 'gmi')
const str = `Текст примерно такой приходит. Киркоров & Пугачева radio edit
или box box nighet`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);