package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(txt$)|(html\.txt$)`)
var str = `happiness.html
joy.png
madness.html.txt
excitement.txt
fear.src`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}